[patch] zap broken heuristic in init/main.c

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[patch] zap broken heuristic in init/main.c

Rob Landley
From: Rob Landley <[hidden email]>
Signed-off-by Rob landley <[hidden email]>

Unknown linux kernel command line arguments are passed through as arguments to
init, unless they have a period in them.
---
I'm trying to run a shell script inside User Mode Linux.  I have an init
wrapper that forks and attaches the child process to /dev/tty0, then waits for
the child to exit.  (I need to do this for ctrl-c to work, pid 1 has kill
blocked and /dev/console has no controlling tty.)  This wrapper uses the
standard execvp(argv[1],argv+1) trick from detach/nohup/setsid and so on.

It worked until I tried to run the production shell script, the name of which
includes the build stage (which has a period in it), and like all the build
shell scripts it ends in .sh.  I get this:

  UML running in SKAS0 mode
  Checking PROT_EXEC mmap in /tmp...OK
  Unknown boot option
    `/home/landley/newbuild/firmware-build/sources/scripts/1.0-tools-umlsetup.sh':
    ignoring
  System halted.

Which sucks.

--- linux-old/init/main.c 2005-09-09 21:42:58.000000000 -0500
+++ linux-new/init/main.c 2005-10-24 02:07:37.683498720 -0500
@@ -242,15 +242,6 @@
  if (obsolete_checksetup(param))
   return 0;
 
- /*
-  * Preemptive maintenance for "why didn't my mispelled command
-  * line work?"
-  */
- if (strchr(param, '.') && (!val || strchr(param, '.') < val)) {
-  printk(KERN_ERR "Unknown boot option `%s': ignoring\n", param);
-  return 0;
- }
-
  if (panic_later)
   return 0;
 
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [hidden email]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/